İçeriğe geç
TREN
Atlıhan Harita

LCC for UE Kullanım Kılavuzu

Linux'ta 3DGS Sahnesi Görüntüleme

Bölüm 03 / 26Kılavuz sürümü v3.5.0Türkçe

Bu belge, Unreal Engine kurulumundan başlayarak LCC4Unreal kurulumunu, C++ projesi oluşturmayı, LCC verisi yüklemeyi, derlemeyi, çalıştırmayı ve bir Linux uygulamasını paketlemeyi kapsar.

ÖğeÖnerilir
İşletim sistemiUbuntu 22.04
İşlemciIntel/AMD dört çekirdekli 2,5 GHz veya üzeri; kaynak koddan derlemeler için daha fazla çekirdek önerilir
Bellek32 GB; kaynaktan derlemeler için 64 GB veya üzeri önerilir
Ekran kartıNVIDIA GeForce RTX 2080 veya daha yüksek performanslı ayrık ekran kartı
Video belleği8 GB veya üzeri
IDEVS Code veya Rider
Disk300 GB ve üzeri

2. Unreal Engine Kurulum Yöntemi Seçin

Linux'ta iki Unreal Engine kurulum yöntemi vardır:

YöntemÖzelliklerUygun olduğu kullanım
Hazır Sürüm (Installed Build)İndirip tamamen çıkardıktan sonra kullanıma hazırdır; C++ projesi oluşturmak daha kolaydırYeni başlayanlar için tercih edilir
Kaynaktan DerlemeMotor kaynağı değiştirilebilir; ilk derleme uzun sürerMotorun veya eklentinin iç yapısını değiştirmesi gereken geliştiriciler

Yalnızca LCC4Unreal gerekiyorsa ve Unreal Engine kaynağını değiştirmeniz gerekmiyorsa hazır sürümü tercih edin.

Not: LCC4Unreal hazır biçimde sunulur ve resmî motor ikili dosyalarıyla uyumludur. Motor kaynağını değiştirmeyin; değiştirilmiş bir motor eklentiyle uyumsuz olabilir, yükleme hatalarına veya anormal davranışa yol açabilir.


  1. Epic'in resmî Unreal Engine for Linux sayfasını açın;
  2. Bir Epic Games hesabıyla oturum açın;
  3. Gereken Unreal Engine sürümünün .zip arşivini indirin.

    Unreal Engine Linux hazır derlenmiş sürümünü Epic Games sayfasından indirin

    Epic Games'in resmî sayfasından gereken Unreal Engine Linux hazır paketini seçip indirin

  4. Dosya yöneticisinde bir motor dizini oluşturun, örneğin:

    /home/[USER]/Unreal/Engines/UnrealEngine
  5. Arşivdeki tüm dosya ve dizinleri bu motor kök dizinine çıkarın. Yalnızca tek bir UnrealEditor dosyasını kopyalamayın; aksi halde motorda çalışmak ve derlemek için gereken diğer içerik eksik kalır;
  6. Dosya yöneticisinde motor kök dizinine girin, boş bir alana sağ tıklayın ve Open in Terminal seçeneğini seçin. Sonraki komutlar doğru motor dizininde çalıştırılmalıdır.

    Unreal Engine kök dizininde bir Linux terminali açın

    Tamamen çıkarılmış Unreal Engine kök dizinine girin ve buradan bir terminal açın

  7. Unreal Engine düzenleyicisini başlatın.

Genel biçim:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

Çalıştırma izni eksik olduğu bildirilirse:

chmod +x "/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
Example:
chmod +x "/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

2.1.1 C++ Geliştirme için Araç Zincirini Hazırlama

Epic Games'in Linux geliştirme hızlı başlangıç kılavuzuna uygun olarak Unreal Engine dizininde aşağıdakini çalıştırın:

cd "/[UE_ROOT]/Engine/Build/BatchFiles/Linux"
./SetupToolchain.sh
Example:
cd "/home/alice/Unreal/Engines/UnrealEngine/Engine/Build/BatchFiles/Linux"
./SetupToolchain.sh

2.2 Yöntem B: Unreal Engine'i Kaynaktan Derleme

Unreal Engine'in kaynaktan derlemesi zaten çalışıyorsa 4. bölüme geçin.

2.2.1 Kaynağı Alma

GitHub'dan alın: https://github.com/EpicGames/UnrealEngine

Unreal Engine kaynak kodunu Epic Games GitHub deposundan alın

Epic Games Unreal Engine GitHub deposunu ziyaret edin ve gereken sürümün kaynağını alın

2.2.2 Bağımlılıkları ve Yerel Araç Zincirini İndirme

cd "/[UE_ROOT]"
./Setup.sh
Example:
cd "/home/alice/Unreal/Engines/UnrealEngine"
./Setup.sh
Unreal Engine kaynak bağımlılıklarını ve Linux araç zincirini indirmek için Setup.sh dosyasını çalıştırın

Kaynaktan derleme için gereken bağımlılıkları ve yerel Linux araç zincirini indirmek için Setup.sh kullanın

Başarı ölçütleri:

  • Komut sonunda normal şekilde döner;
  • fatal iletisi ve işlenmemiş indirme hatası yoktur;
  • Eşleşen Unreal Engine araç zinciri Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux içinde bulunur.

Aşağıdaki görünürse:

fatal: not a git repository

kaynak deposunda, geçerli dizinde veya Git meta verilerinde bir sorun vardır. Bunu yok sayıp derlemeye devam etmeyin. Önce geçerli terminalin doğru Unreal Engine kök dizininde olduğunu doğrulayın.

2.2.3 Proje Dosyalarını Oluşturma

cd "/[UE_ROOT]"
./GenerateProjectFiles.sh
Example:
cd "/home/alice/Unreal/Engines/UnrealEngine"
./GenerateProjectFiles.sh
Unreal Engine proje dosyalarını ve Makefile oluşturmak için GenerateProjectFiles.sh dosyasını çalıştırın

Unreal Engine kaynağı için proje dosyalarını ve Linux Makefile'ı oluşturun

2.2.4 UnrealEditor'ı Derleme

İlk derlemede bellek yetersizliğini önlemek için paralel iş sayısını sınırlayın. make -j4 UnrealEditor varsayılan olarak çalışır; yalnızca 32 GB belleğiniz varsa bunun yerine make -j2 UnrealEditor kullanın; motor Makefile'ı ayrı bir hedef sunmuyorsa make -j4 kullanın:

cd "/[UE_ROOT]"
make -j4 UnrealEditor

# Use this with only 32 GB of memory:
make -j2 UnrealEditor

# Use this when the Makefile provides no separate target:
make -j4
UnrealEditor kaynak hedefini make ile derleyin

Paralel iş sayısını sınırlayın ve UnrealEditor'ın kaynaktan derlemesini yapın

Kaynaktan ilk derlemede yüzlerce, hatta binlerce eylem olması normaldir. Bunlar boş projenin kaynak dosyalarına değil, motorun kendisine aittir. Derleme süresi CPU'ya, belleğe ve diske bağlıdır.

Başarılı olup olmadığını kontrol edin:

test -x "/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" \
  && echo "Source build UnrealEditor is ready" \
  || echo "Build not finished"
Example:
test -x "/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" \
  && echo "Source build UnrealEditor is ready" \
  || echo "Build not finished"

Proje tarayıcısını başlatın:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"
UnrealEditor kaynak derlemesini başlatın ve Unreal Project Browser'ı açın

UnrealEditor'ın kaynaktan derlemesi tamamlandıktan sonra Unreal Project Browser'ı başlatın


3. VS Code'u Kurma ve Yapılandırma

3.1 VS Code ve C++ Geliştirme Araçlarını Kurma

Ubuntu'da resmî Visual Studio Code sitesinden indirip kurun veya dağıtımın desteklediği paket yöntemini kullanın.

VS Code ile C++ projelerini derlemeden önce 2. bölümdeki Unreal Engine Linux araç zinciri kurulumunu tamamlayın ve temel C++ derleme ile hata ayıklama araçlarını hazırlayın. build-essential, clang, lldb ve cmake gibi yaygın araçları Ubuntu sürümüne ve ekip ortamına göre kurun; gerçek derleyici sürümü, geçerli Unreal Engine sürümünün gereksinimlerine ve SetupToolchain.sh/Setup.sh ile kurulan araç zincirine bağlıdır.

Aşağıdaki VS Code uzantıları önerilir:

  • C/C++: kod gezinme, tamamlama ve hata ayıklama;
  • C/C++ Extension Pack: ek yaygın C++ geliştirme özellikleri;
  • CodeLLDB: Linux'ta LLDB ile hata ayıklama;
  • Makefile Tools: Makefile hedeflerini görüntüleme ve çalıştırma (isteğe bağlı).

Epic Games'in resmî belgelerine de başvurabilirsiniz: Setting up VS Code for Unreal Engine.

3.2 VS Code Çalışma Alanını Oluşturma ve Açma

Bir C++ projesi oluşturulduktan sonra proje dizininde normalde .vscode/ ve <ProjectName>.code-workspace bulunur. Eksikse şunu çalıştırın:

"/[UE_ROOT]/GenerateProjectFiles.sh" \
  -vscode \
  -project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -game \
  -engine

VS Code'da File → Open Workspace from File... seçeneğini seçin ve <ProjectName>.code-workspace dosyasını açın. Yalnızca tek bir .cpp dosyası açmayın.

Bir Unreal Engine projesinin code-workspace dosyasını VS Code'da açın

Unreal Engine C++ proje yapılandırmasını yüklemek için oluşturulan .code-workspace dosyasını açın

4. C++ Projesi Oluşturma

4.1 Unreal Engine'i Başlatma

Terminalden çalıştırın:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

4.2 Project Browser Ayarları

Unreal Project Browser'da:

  1. Games seçeneğini seçin;
  2. Blank seçeneğini seçin;
  3. Project Defaults ayarını C++ olarak belirleyin;
  4. Target Platform ayarını Desktop olarak belirleyin;
  5. Quality Preset için ilk testte Scalable, yüksek performanslı iş istasyonunda ise Maximum seçeneğini seçin;
  6. Starter Content seçeneğini ihtiyaca göre belirleyin;
  7. Proje konumunu girin:

    /home/[USER]/Unreal/Projects
  8. Proje adını girin:

    [PROJECT_NAME]
  9. Create düğmesine tıklayın.
Unreal Project Browser'da Games ve Blank C++ şablonunu seçin

Games kategorisinde Blank şablonunu seçin ve proje türünü C++ olarak ayarlayın

Unreal Engine C++ projesinin kayıt konumunu ve proje adını belirleyin

Proje konumunu, adını ve platform seçeneklerini ayarlayın, ardından C++ projesini oluşturun

Proje adı ve yolu için yalnızca şunları kullanın:

  • İngilizce harfler;
  • Rakamlar;
  • Alt çizgiler.

Çince karakterler, boşluk, &, parantez veya diğer özel karakterleri kullanmayın.

4.3 Hazır ve Kaynak Derlemeler Burada Farklı Davranır

Durum A: Hazır Sürüm (Kurulu Derleme)

Olağan akış şöyledir:

create project → auto-compile <ProjectName>Editor → open VS Code → open the new project editor

Eski proje tarayıcı penceresi kısa süreliğine kapanır, çünkü Unreal Engine yeni .uproject dosyasını yükleyen bir editör işlemi başlatır.

Durum B: Kaynak Derleme

Olağan akış şöyledir:

create project → generate Source/, Makefile, .vscode/ → close project browser → open VS Code

Unreal Engine'in kaynak derlemesi yeni projeyi otomatik olarak derleyip açmayabilir; bunun yerine geliştiricinin önce IDE'de veya terminalde derlemesini bekler. Bu bir VS Code yapılandırma hatası değildir ve proje oluşturmanın başarısız olduğu anlamına gelmez.

Bu noktada proje normalde yalnızca şunları içerir:

.vscode/
Config/
Content/
Intermediate/
Saved/
Source/
Makefile
[PROJECT_NAME].code-workspace
[PROJECT_NAME].uproject

Henüz mevcut olmayanlar:

Binaries/Linux/

Bu, proje modüllerinin henüz derlenmediği anlamına gelir.

5. Eklenti Olmadan İlk Derleme

Unreal Engine'in, araç zincirinin ve projenin çalıştığını doğrulamak için boş projeyi LCC4Unreal kurulu değilken bir kez derleyin.

  1. <ProjectName>.code-workspace dosyasını 3.2. bölümde açıklandığı gibi oluşturun ve açın;
  2. VS Code kenar çubuğunda Run and Debug bölümünü açın;
  3. Üstteki yapılandırma listesinden <ProjectName>Editor (Development) seçeneğini seçin;
  4. İlk derlemeyi çalıştırmak için başlat düğmesine tıklayın;
  5. Derlemenin bitmesini bekleyin ve C++ derleme hatası olmadığını doğrulayın. İlk derlemenin uzun sürmesi normaldir.
Projenin Editor Development yapılandırmasını VS Code Run and Debug bölümünde derleyin

<ProjectName>Editor (Development) yapılandırmasını seçin ve projenin ilk C++ derlemesini tamamlayın

Derleme başarılı olduktan sonra VS Code proje editörünü doğrudan başlatabilir.

5.2 İsteğe Bağlı: Proje Makefile Dosyasını Kullanma

cd "/[UE_PROJECTS_DIR]/[PROJECT_NAME]"
make "[PROJECT_NAME]Editor"
Example:
cd "/home/alice/Unreal/Projects/Test2"
make "Test2Editor"
Editor hedefini bir Linux terminalinde proje Makefile'ı ile derleyin

<ProjectName>Editor hedefini proje Makefile dosyası üzerinden derleyin

5.3 Başarılı Derlemeden Sonra Projeyi Açma

Grafik yöntem: Dosya yöneticisinde <ProjectName>.uproject dosyasını bulun, sağ tıklayın ve Open With Unreal Engine Editor seçeneğini seçin. Bu yöntem, sistem hedef Unreal Engine sürümünü zaten doğru biçimde ilişkilendirmişse geçerlidir.

Linux dosya yöneticisinde sağ tıklayarak bir uproject dosyasını Unreal Engine Editor ile açın

Projenin .uproject dosyasına sağ tıklayın ve Unreal Engine Editor ile açmayı seçin

Komut satırı yöntemi: UnrealEditor ve .uproject dosyasının tam yollarını belirtin. Birden fazla Unreal Engine sürümü bir arada bulunduğunda projeyi açmanın daha güvenilir yoludur:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" "/home/alice/Unreal/Projects/Test2/Test2.uproject"

Proje editörde açıldıktan sonra editörü kapatın ve eklenti kurulumuna devam edin.

Unreal Engine belirtilen C++ projesini açıyor

Projeyi belirtilen Unreal Engine sürümüyle yükleyin

C++ projesi Unreal Engine editörünün ana arayüzünde başarıyla açıldı

Boş C++ projesi başarıyla derlenir ve Unreal Engine editöründe açılır

6. LCC4Unreal Kurulumu

Eklentinin Linux sürümünü LCC for Unreal indirme sayfasından edinin ve Unreal Engine sürümünüzle eşleşen paketi indirin.

Eklentiyi kopyalamadan önce:

  1. Projeyi kaydedin;
  2. Unreal Engine editörünü kapatın;
  3. UnrealEditor arka plan işleminin sonlanmasını bekleyin;
  4. VS Code açık kalabilir, ancak aynı anda projeyi derlemeyin.

UnrealEditor'ün hâlâ çalışıp çalışmadığını kontrol edin:

pgrep -a UnrealEditor

Çıktı yoksa editör kapanmıştır.

6.2 Eklentinin Tamamını Projeye Kopyalama

  1. Proje kök dizininde bir Plugins dizini oluşturun:

    mkdir -p "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Plugins"
    Example:
    mkdir -p "/home/alice/Unreal/Projects/Test2/Plugins"
  2. İndirilen eklenti paketini çıkarın ve LCC4Unreal klasörünün tamamını projeye kopyalayın. Son dizin şöyle olmalıdır:

    [PROJECT_ROOT]/Plugins/LCC4Unreal/

    Yalnızca Binaries, Content klasörlerini veya tek tek dosyaları kopyalamayın ve Plugins/LCC4Unreal/LCC4Unreal/ gibi yinelenen iç içe dizin oluşturmayın.

  3. Eklenti tanım dosyasının bulunduğunu doğrulayın. Dizin şunu içermelidir:

    [PROJECT_ROOT]/Plugins/LCC4Unreal/LCC4Unreal.uplugin

    Gerçek .uplugin dosya adı sürüm paketleri arasında değişirse, dosyanın bir alt düzeyde değil, doğrudan Plugins/LCC4Unreal/ altında olduğunu doğrulayın.

LCC4Unreal eklenti klasörünün tamamını projenin Plugins dizinine kopyalayın

LCC4Unreal klasörünün tamamını [PROJECT_ROOT]/Plugins/LCC4Unreal konumuna kopyalayın ve .uplugin dosyasını kontrol edin

6.3 Eklenti Derleme Çıktısını Projeye Kopyalama

Eklenti önceden derlenmiş olarak gelir ve Linux dinamik kütüphane derleme çıktısı eklentinin kendi Intermediate/Build/Linux dizininde bulunur. Paketleme ve çalışma zamanının kütüphaneleri doğru yükleyebilmesi, eksik kütüphane veya tekrarlayan Rebuild istemlerinin önlenmesi için bu çıktıyı projenin ilgili derleme dizinine kopyalamanız gerekir.

Not: Aşağıdaki komutlardaki LCC4Unreal-3.5.0 ifadesini eklenti paketinin gerçek sürüm dizini adıyla değiştirin.

  1. UnrealGame çıktısını kopyalayın. Eklentinin Intermediate/Build/Linux/UnrealGame dizinini projenin Intermediate/Build/Linux/[PROJECT_NAME] dizinine kopyalayın.

    cp -r "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Plugins/LCC4Unreal-3.5.0/Intermediate/Build/Linux/UnrealGame" \
      "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Intermediate/Build/Linux/[PROJECT_NAME]"
    Example:
    cp -r "/home/alice/Unreal/Projects/Test2/Plugins/LCC4Unreal-3.5.0/Intermediate/Build/Linux/UnrealGame" \
      "/home/alice/Unreal/Projects/Test2/Intermediate/Build/Linux/Test2"
    Eklentinin UnrealGame derleme çıktısını projenin Intermediate/Build/Linux dizinine kopyalayın

    Eklentinin UnrealGame derleme çıktısını projenin Intermediate/Build/Linux/[PROJECT_NAME] dizinine kopyalayın

  2. x64 çıktısını kopyalayın. Eklentinin Intermediate/Build/Linux/x64 dizinini projenin Intermediate/Build/Linux/ dizinine kopyalayın.

    cp -r "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Plugins/LCC4Unreal-3.5.0/Intermediate/Build/Linux/x64" \
      "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Intermediate/Build/Linux/"
    Example:
    cp -r "/home/alice/Unreal/Projects/Test2/Plugins/LCC4Unreal-3.5.0/Intermediate/Build/Linux/x64" \
      "/home/alice/Unreal/Projects/Test2/Intermediate/Build/Linux/"
    Eklentinin x64 derleme çıktısını projenin Intermediate/Build/Linux dizinine kopyalayın

    Eklentinin x64 derleme çıktısını projenin Intermediate/Build/Linux/ dizinine kopyalayın

6.4 Projeyi Yeniden Başlatma

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" "/home/alice/Unreal/Projects/Test2/Test2.uproject"

Bu komut hem hangi Unreal Engine'in kullanılacağını hem de hangi projenin açılacağını belirtir. Birden fazla Unreal Engine sürümü bir arada bulunduğunda .uproject dosyasına çift tıklamaktan daha güvenilirdir ve bir sürümün genel varsayılan olarak kaydedilmesini gerektirmez.

6.5 Rebuild İstemi Görüntülendiğinde Yapılacaklar

İstem şuna benzer:

The following modules are missing or built with a different engine version.
Would you like to rebuild them now?

Bu, proje dinamik kütüphanelerinin mevcut olmadığı veya geçerli Unreal Engine sürümüyle eşleşmediği anlamına gelir.

  • Komuttaki Unreal Engine kök yolunun tamamının doğru olduğunu doğruladığınızda Yes/Rebuild seçeneğini seçin;
  • İşlemin hızlı bitmesi ve editörün normal açılması, proje modüllerinin artımlı derlendiğini gösterir;
  • İstem her seferinde görüntüleniyorsa her seferinde farklı bir engine kullanılıp kullanılmadığını, Binaries/Linux dizinine yazılıp yazılamadığını ve sistem saatinin doğru olup olmadığını kontrol edin;
  • Birden fazla engine bulunan ortamda önce istemi kapatın, ardından 13. bölümdeki Build.sh komutuyla açıkça derleme yapın.

7. Veri Formatı için Doğru Actor'ı Seçin

Farklı veri formatları eşleşen Actor'ı gerektirir:

Veri formatıUnreal Engine'de aranacak ActorC++ sınıf adı
.lcc2LCC2ActorALCC2Actor
.lccLCC ActorALCCActor
.sogSogActorASogActor
.spzSpzActorASpzActor
.plyPlyActorAPlyActor

Aşağıdaki adımlarda örnek olarak .lcc2 verisi ve LCC2Actor kullanılır. Diğer formatlar için tablodaki eşleşen Actor'ı kullanın.

7.1 LCC2Actor Ekleme ve Veri Yükleme

  1. LCC4Unreal panelinde LCC2Actor öğesini eklemek için tıklayın.

    LCC4Unreal panelinde sahneye LCC2Actor ekleyin

    LCC4Unreal panelinde .lcc2 veri formatıyla eşleşen LCC2Actor'ı ekleyin

  2. World Outliner içinde LCC2Actor öğesini seçin;
  3. Details panelinde Actions bölümünü bulun;
  4. Load düğmesine tıklayın;
  5. .lcc2 veri dosyasını seçin.

    LCC2Actor'ın Actions panelinde lcc2 verisini seçip yükleyin

    LCC2Actor öğesinin Details panelinden .lcc2 veri dosyasını yükleyin

  6. Verilerin yüklenmesinin bitmesini bekleyin.

    lcc2 verisi başarıyla yüklendi ve Unreal Engine sahnesinde görüntüleniyor

    Yükleme tamamlandığında .lcc2 verileri Unreal Engine görüntüleme alanında görünür

Büyük veriler yüklenirken editör geçici olarak yanıt vermeyebilir. Hemen zorla kapatmak yerine belleği, video belleğini ve Output Log'u izleyin.

8. Varlık Olmayan LCC Verilerini Pakete Dahil Etme

.lcc2, .lcc, .sog, .spz ve .ply dosyaları normalde Unreal Engine .uasset dosyası değildir. Dosyaları yalnızca Content dizinine koymak, bunları kurulum paketine dahil etmez.

Önerilen dizin:

/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Content/LCCData/

Açın:

Edit → Project Settings → Packaging

Bulun:

Additional Non-Asset Directories To Copy

Ekleyin:

LCCData

Packaging altında varlık olmayan dizinler için iki ayar bulunur:

AyarlarVeri biçimiKullanım Senaryosu
Additional Non-Asset Directories To CopyPaketlenmiş çıktıya düz dosyalar olarak kopyalanırVeri, çıktı dizininde görünür kalır ve değiştirilebilir
Additional Non-Asset Directories To PackagePak dosyasına paketlenirVeri ayrı dosyalar olarak sunulmaz, pak dosyasının içinde dağıtılır

Not: Her iki seçenek de tüm özellikleri destekler. Önceki sürümlerde, PLY modelleri ve çarpışma verileri Additional Non-Asset Directories To Package ile pak dosyasına paketlendiğinde yüklenemiyordu; bu sorun düzeltildi.

Girilecek değer, Content altındaki üst düzey bir dizin adıdır (ör. LCCData); dosya yolu değildir. Content/ önekini veya belirli dosya adlarını eklemeyin.

Packaging bölümünde Additional Non-Asset Directories To Copy listesine LCCData ekleyin

Content/LCCData dizinini paketleme sırasında kopyalanan varlık olmayan dizin olarak yapılandırma

Ardından LCC Actor veya LCC2Actor tarafından yüklenen göreli yolun paketlenen dizinle eşleştiğinden emin olun.

8.1 Başlangıç Haritasını Ayarlama

Açın:

Edit → Project Settings → Maps & Modes

Default Maps altında Game Default Map değerini, LCC Actor/LCC2Actor öğesini ve yapılandırılmış veri yolunu içeren hedef seviyeye ayarlayın. Ardından seviyeyi ve proje yapılandırmasını kaydedin; böylece paketlenen uygulama boş bir haritada başlamaz.

Maps and Modes bölümünde Unreal Engine projesinin Game Default Map ayarını yapın

Maps & Modes altındaki Default Maps bölümünden paketlenen uygulamanın açılışta kullandığı Game Default Map değerini ayarlayın

9. Paketleme Öncesi Kontrol Listesi

Paketlemeden önce her maddeyi doğrulayın:

  • [ ] Doğru Unreal Engine sürümü kullanılıyor;
  • [ ] LCC4Unreal eklenti paketi, Unreal Engine sürümüyle ve Linux mimarisiyle eşleşiyor;
  • [ ] <ProjectName>Editor Linux Development başarıyla derleniyor;
  • [ ] Eklenti etkin;
  • [ ] Pro lisansı geçerli (yalnızca Pro sürüm özellikleri kullanıldığında gereklidir, bkz. Sürümler ve Lisanslama);
  • [ ] LCC verileri editör Play modunda görünüyor;
  • [ ] Game Default Map ayarlandı;
  • [ ] Paketlenecek veriler Additional Non-Asset Directories To Copy listesine eklendi;
  • [ ] Diskte yeterli alan var;
  • [ ] Çıktı dizinine yazılabiliyor;
  • [ ] Tüm seviyeler ve varlıklar kaydedildi;
  • [ ] Önce bir Development paketi oluşturun, başarılı olduktan sonra Shipping paketini deneyin.

10. Project Launcher ile Linux için Paketleme

10.1 Project Launcher'ı Açma

Unreal Engine editöründe şunu seçin:

Platforms → Project Launcher
Unreal Engine Platforms menüsünden Project Launcher'ı açın

Platforms menüsünden Project Launcher'ı açın

Tıklayın:

Add → Create Custom Profile
Project Launcher'da özel bir başlatma profili oluşturun

Add → Create Custom Profile yoluyla Linux paketleme profilini oluşturun

10.2 Profili Yapılandırma

  1. Özel profilde hedef platform olarak Linux seçin ve içerik paketleme düzenini Pak dosyası olarak ayarlayın;
  2. Derleme sonucunun arşivlenmesini etkinleştirin ve yazılabilir bir arşiv dizini seçin. Dağıtılabilir sürüm, paketlemeden sonra fiilen bu dizine kaydedilir.

    Project Launcher özel profilinde Linux ve Pak seçeneklerini seçin, arşiv dizinini belirleyin

    Hedef platformu Linux olarak ayarlayın, Pak file seçeneğini seçin, arşivlemeyi etkinleştirin ve paketleme çıktı dizinini belirtin

  3. Özel profilin sağındaki başlat simgesine tıklayın.

Paketleme normalde şunları içerir:

Build → Cook → Stage → Package → Archive

İlk paketleme, sonraki artımlı paketlemeden daha yavaştır. Kısa süre aynı yüzdede kaldı diye işlemi zorla durdurmayın. Başarılı olduğunda aşağıdakine benzer bir çıktı görünür:

BUILD SUCCESSFUL

10.3 "Querying" Durumunda Kalırsa

Aşağıdakileri sırayla kontrol edin:

  1. Unreal Engine'in platform ve SDK algılamasını tamamlamasını bekleyin;
  2. Window → Developer Tools → Output Log yolunu açın;
  3. Turnkey, SDK, Linux, Error terimlerini arayın;
  4. Mevcut ana bilgisayarın Linux olduğunu ve hedef platformun da Linux olduğunu doğrulayın;
  5. Unreal Engine kaynak derlemesinin bağımlılıklarının ve araç zincirinin Setup.sh ile kurulduğunu doğrulayın;
  6. Önceden derlenmiş sürüm için SetupToolchain.sh komutunun çalıştırıldığını doğrulayın;
  7. Yinelenen Project Launcher pencerelerini kapatıp yeniden açın;
  8. Aynı projeyi aynı anda başka bir terminalde derlemeyin.

11. Komut Satırından Paketleme (isteğe bağlı)

Grafik arayüzle paketleme kararlı çalıştıktan sonra RunUAT kullanılabilir:

mkdir -p "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Packaged"

"/[UE_ROOT]/Engine/Build/BatchFiles/RunUAT.sh" BuildCookRun \
  -project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -noP4 \
  -targetplatform=Linux \
  -clientconfig=Development \
  -build \
  -cook \
  -stage \
  -pak \
  -archive \
  -archivedirectory="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Packaged"
Example:
mkdir -p "/home/alice/Unreal/Projects/Test2/Packaged"

"/home/alice/Unreal/Engines/UnrealEngine/Engine/Build/BatchFiles/RunUAT.sh" BuildCookRun \
  -project="/home/alice/Unreal/Projects/Test2/Test2.uproject" \
  -noP4 \
  -targetplatform=Linux \
  -clientconfig=Development \
  -build \
  -cook \
  -stage \
  -pak \
  -archive \
  -archivedirectory="/home/alice/Unreal/Projects/Test2/Packaged"

-archive ve -archivedirectory ile son çalıştırılabilir sürümü Saved/StagedBuilds/Linux içinde olduğunu varsaymak yerine belirtilen arşiv dizininde arayın.

Proje belirli haritalar kullanıyorsa proje ayarlarına ve mevcut Unreal Engine'in komut parametrelerine göre harita kısıtlamaları ekleyin. Eksik komut parametrelerinden kaynaklanan eksik paketleri önlemek için yeni başlayanlar önce Project Launcher'ı kullanmalıdır.

12. Paketlenen Sonucu Çalıştırma

12.1 Arşivlenen Sonucu Çalıştırma

Project Launcher'da arşivleme etkinleştirildiyse veya RunUAT ile -archive -archivedirectory="..." kullanıldıysa, fiilen yapılandırılan arşiv dizinine gidin. Unreal Engine sürümüne göre orada ek bir Linux alt dizini oluşturulabilir; bu yüzden önce proje başlatma betiğini bulun, ardından çalıştırın:

cd "/[ARCHIVE_DIR]"
find . -maxdepth 3 -type f -name "*.sh" -print

chmod +x "./[SUBDIR]/[PROJECT_NAME].sh"
"./[SUBDIR]/[PROJECT_NAME].sh"
Example (archived result in Packaged/Linux):
cd "/home/alice/Unreal/Projects/Test2/Packaged"
find . -maxdepth 3 -type f -name "*.sh" -print
chmod +x "./Linux/Test2.sh"
"./Linux/Test2.sh"
Arşivlenen paketleme sonucunu Linux dosya yöneticisinde görüntüleyin ve başlatın

Project Launcher veya RunUAT'ta yapılandırılan arşiv dizinine girin ve proje betiğini başlatın

12.2 Arşivlenmemiş Staged Çıktıyı Çalıştırma

Yalnızca arşivleme yapılmadıysa ve staged sonucun doğrudan kontrol edilmesi gerekiyorsa aşağıdaki dizinden çalıştırın:

cd "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Saved/StagedBuilds/Linux"
chmod +x "./[PROJECT_NAME].sh"
"./[PROJECT_NAME].sh"
Example:
cd "/home/alice/Unreal/Projects/Test2/Saved/StagedBuilds/Linux"
chmod +x "./Test2.sh"
"./Test2.sh"

Çalıştırdıktan sonra kontrol edin:

  • Uygulama başlıyor;
  • Varsayılan harita doğru;
  • LCC verileri görünüyor;
  • Uygulama kapatıldıktan sonra arka planda çalışan işlem kalmıyor.
Yüklenen LCC sahnesini gösteren paketlenmiş Linux uygulamasını çalıştırın

Paketlenen Linux uygulamasını başlatın; varsayılan haritayı, LCC verilerini ve lisanslı özellikleri doğrulayın

13. Komut Başvurusu

Aşağıdaki komutlardaki [UE_ROOT], [UE_PROJECTS_DIR], [PROJECT_NAME] ve [ARCHIVE_DIR] yer tutucudur. Çalıştırmadan önce bunları gerçek tam yollar ve adlarla değiştirin.

Proje tarayıcısını başlatın:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

VS Code proje dosyalarını oluşturma:

"/[UE_ROOT]/GenerateProjectFiles.sh" \
  -vscode \
  -project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -game \
  -engine
Example:
"/home/alice/Unreal/Engines/UnrealEngine/GenerateProjectFiles.sh" \
  -vscode \
  -project="/home/alice/Unreal/Projects/Test2/Test2.uproject" \
  -game \
  -engine

Proje Editor hedefini derleme:

"/[UE_ROOT]/Engine/Build/BatchFiles/Linux/Build.sh" \
  "[PROJECT_NAME]Editor" Linux Development \
  -Project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -WaitMutex
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Build/BatchFiles/Linux/Build.sh" \
  "Test2Editor" Linux Development \
  -Project="/home/alice/Unreal/Projects/Test2/Test2.uproject" \
  -WaitMutex

Belirli bir projeyi belirli bir Unreal Engine ile açma:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject"
Example:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" "/home/alice/Unreal/Projects/Test2/Test2.uproject"

Arşivlenen sonucu çalıştırma:

cd "/[ARCHIVE_DIR]"
find . -maxdepth 3 -type f -name "*.sh" -print
chmod +x "./[SUBDIR]/[PROJECT_NAME].sh"
"./[SUBDIR]/[PROJECT_NAME].sh"

Arşivlenmemiş staged çıktıyı çalıştırma:

cd "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Saved/StagedBuilds/Linux"
chmod +x "./[PROJECT_NAME].sh"
"./[PROJECT_NAME].sh"
Example (unarchived staged output):
cd "/home/alice/Unreal/Projects/Test2/Saved/StagedBuilds/Linux"
chmod +x "./Test2.sh"
"./Test2.sh"

Bu bölüm XGRIDS'in resmî kullanım kılavuzundan Türkçeye çevrildi; ekran görüntüleri ve arayüz adları özgün haliyle İngilizcedir. İngilizce aslı (yeni sekmede açılır) · Güncelleme:

XGRIDS Türkiye

Kurulumda ve Sahada Yanınızdayız

Atlıhan Harita; cihaz kurulumu, firmware güncellemesi, yazılım kullanımı ve saha uygulamalarında eğitim ve teknik destek verir. Sorunuzu iletin, uzmanımız size dönsün.

+90 216 546 0804